Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
03967 Misc. Minor Always Jul 31, 2010, 19:48 7 days ago
Tester Q.T.Quazar View Status Public Platform MAME (Official Binary)
Assigned To Kale Resolution Fixed OS Windows Vista/7 (32-bit)
Status [?] Resolved Driver kaneko16.cpp
Version 0.139 Fixed in Version 0.190 Build Normal
Summary 03967: shogwarr; shogwarru; fjbuster (untested): Game cannot be replayed from .inp file
Description Rather bizarre... from at least .134 on, the .inp file does not synch with playback--regardless of NVRAM, frameskipping, sound, core settings, .cfg file, or anything else.

Fighting against some opponents does seem to synch properly--but others, such as Shogun, always desynch.

This behaviour did not seem to happen back around the .106 cycle (although i have not tested exhaustively)

Maybe somewhat minor, but seems to me desynching replays have often been an indicator of emulation errors.
Steps To Reproduce make an .inp. choose Samurai to play, since he fights Shogun first. play a round or two. quit. playback .inp.
Additional Information attached file made on .137--should be almost a complete game. instead, it desynchs in the first match.
Flags
Regression Version
Affected Sets / Systems shogwarr; shogwarru; fjbuster (untested)
Attached Files
zip file icon shogwarr_007.zip (762,677 bytes) Jul 31, 2010, 19:48
Relationships
related to 04209ResolvedKale brapboys, bloodwar: Playback lose sync 
Notes
2
User avatar
No.06466
Haze
Senior Tester
Aug 1, 2010, 00:29
The game didn't even work around .106

I've noticed the same with B.Rap Boys which is the same hardware anyway, I suspect something the games depend on isn't being initialized, not sure what tho, I tried a bunch of things and didn't manage to get BRB to playback properly.
User avatar
No.14249
Kale
Developer
7 days ago
Wasn't even aware there was a bug report for this ...