Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06721 Sound Critical (emulation) Always Oct 18, 2017, 13:02 30 days ago
Tester wuemura View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Confirmed Driver playch10.cpp
Version 0.190 Fixed in Version Build 64-bit
Summary 06721: pc_drmro, pc_mtoid: [possible] Audio loop
Description After the game demo, there is a audio loop tone that gone forever when it get back to the "Playchoice" screen. I don't have more roms to test with, it might affect other machines too.
Steps To Reproduce Start one of the listed games and let it run.
Additional Information
Flags Possible
Regression Version
Affected Sets / Systems pc_drmro, pc_mtoid
Attached Files
 
Relationships
There are no relationsihp linked to this issue.
Notes
2
User avatar
No.14298
Tafoid
Administrator
Oct 18, 2017, 14:38
I'd like confirmation on actual hardware before this gets looked at further. I'm not convinced that this isn't original behavior. It'll only happen on an actual machine, I'm sure, after you've entered credit/time, selected the machine and spent many dozens of seconds waiting out the transition to the control panel screen. Most games do not have lingering title screen tunes and who is going to spend up to half of their game time looking at the title screen before starting up? I'm fairly positive it was assumed that the game would be started by the user ASAP.

If there is one issue is that, in forcing a single game run PlayChoice 10 entries, we force the game to "boot" whereas the original PlayChoice 10 machines will not "boot" until you choose the game from the selection screen after coining up. This setup will be better served by a multi-slot hookup much like we have for Neo Geo games and using the bios as the main set to run.

That said, only pc_mtoid shows the hanging note as you described in my testing. pc_drmro was silent when it got to the control panel screen.
User avatar
No.14301
wuemura
Tester
Oct 18, 2017, 16:44
I've tested this with Linux official and GIT, still happens.
pc_drmro loops audio at the control panel screen.

When it does it return a bunch of this:
[:cart:nesapu] invalid apu write: $00 at $0009
[:cart:nesapu] invalid apu write: $00 at $0009
[:cart:nesapu] invalid apu write: $00 at $0009
[:cart:nesapu] invalid apu write: $00 at $0009
hiscore: write_scores
hiscore: write_scores output
hiscore: write_scores end

When the game resume demo mode and get out from "hiscore", the audio loop stop and get normal all over again until it get back to the control panel screen.