Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06791 Graphics Minor Always Dec 9, 2017, 00:33 11 days ago
Tester izius View Status Public Platform MAME (Official Binary)
Assigned To AJR Resolution Fixed OS Windows Vista/7/8 (32-bit)
Status [?] Resolved Driver splash.cpp
Version 0.192 Fixed in Version 0.194GIT Build 32-bit
Summary 06791: splash and clones: Wrong sprite priority on bonus items
Description If I remember correctly, bonus items in Splash! are made by 2 sprites drawn over each other: a polygon and an icon (4 mini bombs, a gun, etc) to indicate the type of bonus.

In MAME only the polygon is shown.
Steps To Reproduce Play the game until a bonus shows up.

Bonuses actually seem to be time based; you could stay in the starting spot and shoot bubbles coming in you way, without ever moving, and in a couple of minutes a bonus should appear.

Also, the bombs bonus appears very briefly during the demo play in the attract mode.
Additional Information Marked as possible, since I found no PCB videos showing bonuses and it's been 20+ years I don't see a Splash! machine.

A small clue of this bug: on the blue diamond shaped bonus (the one giving 4 bombs) there is a red pixel halfway the upper right side, which should be the burning fuse of one of the bombs.

EDIT: uploaded some photos of the bonuses on a PCB (see Notes below).
Removed the Possible flag, and set Verified with Original.
Flags Verified with Original
Regression Version
Affected Sets / Systems splash and clones
Attached Files
png file icon 0000.png (5,963 bytes) Dec 9, 2017, 00:33 Uploaded by izius
izius
jpg file icon Foto 06-01-18, 11 37 08.jpg (2,748,834 bytes) 14 days ago Uploaded by izius
Yellow circle bonus on a PCB
jpg file icon Foto 06-01-18, 11 37 58.jpg (3,934,945 bytes) 14 days ago Uploaded by izius
Blue diamond bonus on a PCB
Relationships
There are no relationsihp linked to this issue.
Notes
3
User avatar
No.14507
B2K24
Moderator
Dec 9, 2017, 05:43
Acknowledging for now while this can be researched/figured out.
User avatar
No.14629
izius
Tester
14 days ago
Uploaded a couple of photos taken by Kold666 while testing a donated PCB.
That board was a bit faulty on the graphics side, but the photos should be clear enough to prove this bug.
User avatar
No.14638
AJR
Developer
11 days ago
This video on YouTube appears to be recorded from an original PCB:



No powerups make an appearance here, but it shows the title (before and after it bursts) appearing over the other colored bubbles, instead of behind them. This has convinced me that reversing the sprite drawing order is the correct way to fix this.