Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07012 Interface Critical (emulator) Always 11 days ago 11 days ago
Tester wuemura View Status Public Platform MAME (Official Binary)
Assigned To Resolution Invalid report OS Windows 10 (64-bit)
Status [?] Closed Driver model1.cpp
Version 0.198 Fixed in Version Build 64-bit
Summary 07012: vr: INP playback makes MAME crash
Description
mame64_198 vr -playback vr.inp
Input file: vr.inp
INP version 3.0
Created Sun Jun 10 06:55:22 2018
Recorded using MAME 0.196 (unknown)

-----------------------------------------------------
Exception at EIP=0000000003a4b5bc (ioport_port::read()+0x022c): INTEGER DIVIDE BY ZERO
-----------------------------------------------------
RAX=0000000000640000 RBX=0000000000ffff00 RCX=0000000000000000 RDX=0000000000000000
RSI=112e0be826d694b3 RDI=f21f494c589c0000 RBP=000000000d657ea0 RSP=000000000d657e20
 R8=00000000ffff0000 R9=0000000000000000 R10=00000000107a70f0 R11=000000000d657e1f
R12=00000000108e3120 R13=0000000000000000 R14=000000000d658670 R15=000000000f957160
-----------------------------------------------------
Stack crawl:
  000000000d657e40: 0000000003a4b5bc (ioport_port::read()+0x022c)
  000000000d657ff0: 0000000003a5caa8 (ioport_manager::frame_update()+0x0588)
  000000000d658200: 0000000003a5f517 (ioport_manager::load_config(config_type, util::xml::data_node const*)+0x0a27)
  000000000d6584c0: 000000000397059f (configuration_manager::load_settings()+0x08ff)
  000000000d658560: 0000000003a69a46 (running_machine::run(bool)+0x0066)
  000000000d65f210: 000000000228f2da (mame_machine_manager::execute()+0x020a)
  000000000d65f4c0: 00000000022fd5d4 (cli_frontend::start_execution(mame_machine_manager*, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&)+0x03f4)
  000000000d65f630: 00000000022fda95 (cli_frontend::execute(std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)+0x0045)
  000000000d65f690: 000000000228d28a (emulator_info::start_frontend(emu_options&, osd_interface&, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&)+0x002a)
  000000000d65fe50: 000000000774a49d (main+0x017d)
  000000000d65ff20: 00000000004013c7 (__tmainCRTStartup+0x0247)
  000000000d65ff50: 00000000004014fb (mainCRTStartup+0x001b)
  000000000d65ff80: 00007ff800cd3034 (BaseThreadInitThunk+0x0014)
  000000000d65ffd0: 00007ff8017c1551 (RtlUserThreadStart+0x0021)
Steps To Reproduce Delete previous nvram
mame64_198 vr -playback vr.inp
Additional Information This bug doesn't affect other machines that I've tested with.
Flags
Regression Version
Affected Sets / Systems vr
Attached Files
zip file icon vr.zip (9,378 bytes) 11 days ago Uploaded by wuemura
INP file
7z file icon wr_0198.7z (15,703 bytes) 11 days ago Uploaded by Tafoid
Recorded from 0.198 for 30 seconds (vr)
Relationships
There are no relationsihp linked to this issue.
Notes
14
User avatar
No.15139
Tafoid
Administrator
11 days ago
You output says 'recorded using 0.196 (unknown)'
Try using 0.198 to record then playback?
.inp recordings are not guaranteed to be used between versions especially in this case where major changes to I/O happened with Model 1 games.
User avatar
No.15141
wuemura
Viewer
11 days ago
That is a official binary.
I need to report a regression with model1 that happens on 0.198.
User avatar
No.15142
Tafoid
Administrator
11 days ago
edited on: 11 days ago
You must be using the wrong binary. Why would it not report the version correctly?!?

I tried 0.198 just now:
mame vr -record wr.inp -str 30
I credited, started a game and started racing, even changing camera angles at the end without any issues.
I've attached my .inp file I just made which you can -playback. It plays back locally without issue.

Yes, I named it wr to keep it different than the gamename and not confuse it with yours.

User avatar
No.15143
wuemura
Viewer
11 days ago
edited on: 11 days ago
vr is working on 0.196, and is broken on 0.198.
To reproduce the error, I need to mimic what happens on 0.196 to put side by side with 0.198.

Recording vr on 0.198 is not the issue, it works.

User avatar
No.15144
Tafoid
Administrator
11 days ago
How is vr broken in 0.198? I'm able to play it just fine.
User avatar
No.15145
wuemura
Viewer
11 days ago
edited on: 11 days ago
The racing street is very unstable on corners, it shakes way to often if you compare with 0.196.
The racing cars in front of you always crash at the first corner, you can note the tire screech sound effect followed by a crash sound, some times cars crash on other corners too.
The track is the first one on the left.

User avatar
No.15146
wuemura
Viewer
11 days ago
edited on: 11 days ago
The audio on 0.196 is very good on Linux, on 0.198 is choppy. The video motion is working fine but the audio keep cutting out every few seconds.

User avatar
No.15147
wuemura
Viewer
11 days ago
This is how vr play before 0.198, the cars at the corner never crash and the racing street are much more stable, specially on the corners.
User avatar
No.15149
Robbbert
Developer
11 days ago
No crash here, game appears to working perfectly.
User avatar
No.15150
wuemura
Viewer
11 days ago
Use my INP, it will crash.
User avatar
No.15153
Robbbert
Developer
11 days ago
Your inp comes from an old version. The driver has been worked on since then, which makes old inps invalid.
User avatar
No.15154
Tafoid
Administrator
11 days ago
edited on: 11 days ago
Since you didn't read it before, I'll put it in full caps:

.INP RECORDINGS ARE NOT GUARANTEED TO BE USABLE BETWEEN VERSIONS ESPECIALLY IN THIS CASE WHERE MAJOR CHANGES TO I/O HAPPENED WITH MODEL 1 GAMES.

In other words, your verbage you quoted shows you tried to use a 0.196 recording on 0.198. This isn't guaranteed to work and may crash.
if you can produce a -record which is made with 0.198 like I did, it should -playback without issue like in my case:

RECORD:
F:\OLDER_MAME>mame64_198 vr -record wr.inp -str 30
Average speed: 100.00% (29 seconds)

PLAYBACK:
F:\OLDER_MAME>mame64_198 vr -playback wr.inp
Input file: wr.inp
INP version 3.0
Created Sun Jun 10 06:39:48 2018

Recorded using MAME 0.198 (mame0198)
Total playback frames: 1727
Average recorded speed: 99%
Average speed: 100.00% (31 seconds)

User avatar
No.15155
wuemura
Viewer
11 days ago
Understood.
How about the issue with vr?
User avatar
No.15156
Tafoid
Administrator
11 days ago
For the record, the crash only happens when you use 0.198 with your recording. (confirmed locally) Plyaback on 0.196 works ok as expected.
There is no .inp bug here and I have confirmation from another Dev showing the same thing.

Closing as Invalid since you are using mismatched .inp files (0.196 input, 0.198 binary) and normal 0.198 recording/playback works ok.
Again, if you have other issues, talk it out with people first at a forum or chatbox or IRC or a large selection of other destinations. Do not use MT to talk about one thing and shift issues elsewhere. Keep on point and focused on one report at a time for the time being - makes it easier for all of us involved.