Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
02778 Sound Minor Always Dec 27, 2008, 19:34 21 days ago
Tester Endaar View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS
Status [?] Confirmed Driver namcos2.cpp
Version 0.128u6 Fixed in Version Build Normal
Summary 02778: suzuka8h, suzuk8h2, finallap, finalap2, finalap3, fourtrax + clones: Music Playback becomes buzz/humming
Description Shortly after starting the game - basically, as you get on the motorcycle - the music stops playing and turns into a loud hum. Sound effects continue to work normally and the game is playable.
Steps To Reproduce Insert coin, start game.
Additional Information I tried a number of other games with the same driver. This issue appears to exist in Final Lap and Four Trax, although in both it is less noticeable. Four Trax's music actually worked briefly after the race started but then turned into a hum as well.

I did not try every single game sharing the driver, but a number of others work normally.

suzuk8hj -> suzuka8hj in 0.133u1
Flags
Regression Version
Affected Sets / Systems suzuka8h, suzuk8h2, finallap, finalap2, finalap3, fourtrax + clones
Attached Files
wav file icon suzuka.wav (226,348 bytes) Dec 27, 2008, 20:50
Relationships
There are no relationship linked to this issue.
Notes
4
User avatar
No.03417
Haze
Senior Tester
Dec 27, 2008, 20:34
the buzzing is the engine sound... probably wrong tho, definitely sounds strange.

the ym2151 is silent at this point, so if it's meant to be playing some music, that is also a bug.
User avatar
No.03418
Endaar
Tester
Dec 27, 2008, 20:52
I just uploaded a quick audio clip of what happens for me. This is right as the game itself starts and the rider is on track ready to run to the bike. There appears to be music which then turns into the hum. Maybe what I'm thinking is music though is just a sound effect. Anyway, hope it helps.
User avatar
No.16553
Osso
Developer
29 days ago
Video reference:
User avatar
No.16590
Osso
Developer
21 days ago
According to Guru, testing on his real Final Lap 3 PCB:
"on real hardware if the voice2 ROM is removed there's still in-game sound whereas in MAME there are no in-game sounds and if both voice ROMs are removed from the PCB the in-game sound is almost exactly like in MAME, which suggests the voice ROMs are incorrectly mapped or a mirror mapping is missing."

I guess it could also be different c140 banking. Currently the device has 3 different banking types but maybe there's at least a fourth one?