Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
03472 Sound Minor Always Oct 9, 2009, 08:32 Feb 21, 2018, 20:21
Tester georgc3 View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS
Status [?] Confirmed Driver midvunit.cpp
Version 0.134 Fixed in Version Build
Summary 03472: wargods : The Sound D/RAM chip fails during the Post and the "Listen for Tone" fails as well during the post.
Description When starting the game on the official version, the post runs through its tests, the diagnostic results shows Sound S/RAM has failed and has an ERROR EE and Listen for Tone has an ERROR E1 The game will load and is fine but the volume of the sound is so low so I had to press F2 to go to the service mode to adjust the volume so high in order to hear the normal quality of sound.
Steps To Reproduce Start the game after you have the rom and chd file for War Gods. After the ROMs are tested, the RAMs should good. The results will show that the Sound S/RAM is bad and reads ERROR EE and Listen for Tone reads ERROR E1. It will also say the 15 RAM Sets have passed and 2 have failed. Pressing any button will allow the game to load with the sound being so low. Press F2 to go to the service mode and scroll down to volume adjustment and turn all the way up in order to hear the normal volume of sound again. If you want it louder, then may adjust volume on your computer.
Additional Information
Flags
Regression Version 0.130
Affected Sets / Systems wargods
Attached Files
png file icon wargodsmame0126.png (7,622 bytes) Oct 10, 2009, 03:45
png file icon wargodsmame134.png (6,760 bytes) Oct 10, 2009, 03:51
Relationships
There are no relationsihp linked to this issue.
Notes
4
User avatar
No.05022
Haze
Senior Tester
Oct 9, 2009, 13:07
I doubt the sound volume is related to the tests failing. Most midway games of this generation have quiet sound by design.

I think the bug report should be simplified to reflect the test failures only.
User avatar
No.05027
georgc3
Tester
Oct 10, 2009, 03:47
edited on: Oct 10, 2009, 03:51
Well, I just tested this on the command-line version of mame 0.126. The Sound D/RAM have passed and Listen for Tone have passed as well where you can actually hear the tone on mame 0.126. On mame 0.134 you can't since it failed so I uploaded the .png file from war gods post running on mame 0.126 and the one running from command-line version of mame 0.134 to show the difference.
User avatar
No.08149
SpecLad
Tester
Feb 5, 2012, 14:58
This bug was introduced in revision 4722, with this change:

 static READ16_HANDLER( dcs_polling_r )
 {
- cpu_eat_cycles(space->cpu, 1000);
+ if (dcs.polling_count++ > 5)
+ cpu_eat_cycles(space->cpu, 10000);
        return *dcs_polling_base;
 }

The number of cycles changed from 1000 to 10000. Now, I have no idea what that actually does, but if you change it back to 1000, it fixes the bug.
User avatar
No.14769
M.A.S.H.
Senior Tester
Feb 21, 2018, 20:21
Added "Regression Version": 0.130 (9th March 2009)
SpecLad tip is still working:
If you changed READ16_MEMBER( dcs_audio_device::dcs_polling_r ) in mame\audio\dcs.cpp line 2094
from
space.device().execute().eat_cycles(10000);
to
space.device().execute().eat_cycles(1000);

the game boots without this error!