Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07192 Interface Minor Always Dec 31, 2018, 09:50 4 days ago
Tester ZX3000GT1 View Status Public Platform MAME (Official Binary)
Assigned To Resolution Unable to reproduce OS Windows 10 (64-bit)
Status [?] Closed Driver
Version 0.205 Fixed in Version Build 64-bit
Summary 07192: Selected ROM filter not saving at all
Description Any changes to the ROM filter (Unfiltered -> Available for example) will not be saved upon exit, with the next launch going back to 'Unfiltered'.

ui.ini has "remember_last" within "UI MISC OPTIONS" as 1 and "last_used_filter" shows the correct value upon exiting MAME ("Available" if it's selected before), but relaunching MAME will bring back the ROM filter to "Unfiltered"
Steps To Reproduce 1. Run MAME
2. Change ROM filter to any other but 'Unfiltered'
3. Exit MAME
4. Relaunch MAME
5. ROM filter is in 'Unfiltered'
Additional Information
Flags
Regression Version
Affected Sets / Systems
Attached Files
mp4 file icon UM4Ms8ov77.mp4 (1,966,695 bytes) Dec 31, 2018, 09:50 Uploaded by ZX3000GT1
txt file icon verbose.txt (14,454 bytes) Jan 7, 2019, 04:22 Uploaded by ZX3000GT1
[Show Content]
Relationships
There are no relationship linked to this issue.
Notes
5
User avatar
No.16012
Robbbert
Developer
Jan 6, 2019, 09:01
Works correctly for me.
User avatar
No.16013
ZX3000GT1
Tester
Jan 6, 2019, 11:43
That's the thing, I dunno what happened. It used to work before, now pretty much every version i've tested (0.195, 0.201-0.205, etc) have this issue.
User avatar
No.16014
MetalGod
Senior Tester
Jan 6, 2019, 13:44
Works correctly for me too.
Tested on windows 7 and windows 10 (64 bits both)
Are you testing this on a clean mame installation?
User avatar
No.16016
ZX3000GT1
Tester
Jan 7, 2019, 04:03
edited on: Jan 7, 2019, 04:22
Yup, directly downloaded from mame.net
[EDIT] Verbose log added
User avatar
No.16257
Robbbert
Developer
4 days ago
Must be a local issue, works for me.