Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06197 DIP/Input Major Random May 1, 2016, 03:02 May 1, 2016, 22:53
Tester MichaelMichael54321 View Status Public Platform MAMEUI
Assigned To Resolution Invalid report OS Windows Vista/7/8 (64-bit)
Status [?] Closed Driver namcos22.cpp
Version 0.173 Fixed in Version Build 64-bit
Summary 06197: acedrvrw, victlapw, dirtdash: [possible] XInput - Right and Left (Triggers) not recongized
Description (Tested with MAMEUIFX 0.173 64-bit)

I always set my gas and brake pedal analogs to right and left triggers (respectively) when playing racing games. My car doesn't move (in addition to starting in Free Play and selecting class and courses)

The following things have been done, in chronological order:
* Deleting the personal game configs, followed by default and _empty configs
* Clearing the NVRAM
* Disconnecting and reconnecting my Microsoft Gaming Receiver
* Trying the other 2 Xbox 360 controllers I own (Not even that didn't work)
* Doing a clean MAMEUIFX reinstall
* Restarting my PC
* Using official MAME 0.173 64-bit (this was the last resort)

I haven't tested the other Namco System 22 games, but I feel like it affects them as well...
Steps To Reproduce 1. Start the game from the MAMEUIFX menu.

2. Set the gas pedal analog to the right trigger and the brake pedal to the left trigger.

3. Try to move the car when the race starts.
Additional Information Evidence to help this is my Dirt Dash video:

The version used is the 0.173 MAMEUIFX I described, and the controls are fine...I added the "Possible" flag because of it.
Flags Possible
Regression Version
Affected Sets / Systems acedrvrw, victlapw, dirtdash
Attached Files
png file icon Controls.png (964,862 bytes) May 1, 2016, 03:02 Uploaded by MichaelMichael54321
This is the controls I use in both Ace Driver: Victory Lap and it's prequel, Racing Evolution.
Relationships
There are no relationsihp linked to this issue.
Notes
2
User avatar
No.12581
MichaelMichael54321
Tester
May 1, 2016, 22:37
Please close...this problem was solved...I did check the I/O Switch test menu and saw that the Gas was negative the max of it (but the Brake was fine), apparently resetting with the Test Menu dipswitches on (or clearing the NVRAM again) must of work. I mainly suspect the namcoc74 ROM that is required to run the games that it extends into other System 22 games (like Dirt Dash)

All in all, it's finally fixed.
User avatar
No.12582
Robbbert
Developer
May 1, 2016, 22:53
Closed as requested