Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06255 Gameplay Minor Always Jun 23, 2016, 23:21 Aug 10, 2016, 20:14
Tester Augusto View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Acknowledged Driver
Version 0.174 Fixed in Version Build 64-bit
Summary 06255: powerins and others sets: Issues using controllers with analog buttons
Description I has removed the original post because was figured the because of issues with game controller.
My controller is an xinput with analog buttons.
If is configured an MAME button to use analog buttons on game controller the button is slow to make action.
The analogs are L2 and R2.
If using sf2hj and MAME button 6 is gamepad R2 if I press R2 has an high latency to make action.
Digital buttons has the action in same time that is pressing the buttons. Analog has high latency and if is all time being pressing not make action. Analog buttons on gamepad make action just if I stop of pressing.
Example
MAME button - Game Controller
1 - Square
2 - X
3 - R1 Digital
4 - Triangle
5 - Circle
6 - R2
Have issue just in button 6. High latency to make action and if pressing not make action.
Another example
MAME Button - Game Controller
1 - Square and L1
2 - X and L1
3 - R1 and L1
4 - Triangle and L2
5 - Circle and L2
6 - R2 and L2
Have issues in buttons 4,5 and 6. All buttons not make any action same pressing all time. Is how if any code was added in input core for racing analog controll or other type of game or yet some configuration on MAME.INI that not is in whatsnew or MAME UI Config menu.
Using one button being three MAME buttons is good for some games.
The configuration above not has issues in 0.168 and the game controller not has issues with others emulators.
Using Keyboard not has issues.
Thanks.
Steps To Reproduce
Additional Information
Flags
Regression Version
Affected Sets / Systems powerins and others sets
Attached Files
 
Relationships
There are no relationsihp linked to this issue.
Notes
11
User avatar
No.12803
Tafoid
Administrator
Jun 24, 2016, 16:17
Autofire is not a guaranteed function in any way. Any malfunction that comes about when attempting to use (since it is only usable when you have -cheat active) it is not something we can consider an emulation error because the original machines did not have autofire.
User avatar
No.12807
Augusto
Tester
Jun 24, 2016, 19:42
edited on: Jun 25, 2016, 00:39
Yes you are correct.
I not say reference for emulation.
If autofire was implemented on MAME the coder can see the post and fix. An post for autofire coder.
sfthj also is affected.
Here I seeing an detail .. the issue is with anothers games using more of 4 buttons and perhaps not is related with autofire.
Testing with anothers games. After I post here an result.

User avatar
No.12812
B2K24
Moderator
Jun 26, 2016, 01:50
I can confirm this behavior, but am also in agreement with Tafoid. Where is the proper place to report this issue?
Is the something Pugsy can look at and should it be reported on his forums?
User avatar
No.12822
Augusto
Tester
Jun 27, 2016, 10:34
edited on: Jun 27, 2016, 11:28
I had originally posted with details saying when enable autofire the button fire is auto.
After of testing with anothers games I see any game using more of 3 buttons has issues when using my xinput controller. The buttons are pressing all time and is the because when enable autofire the button is how if I is pressing the button. If using just keyboard not has issues even if enabling autofire.
Perhaps not is an issue with the autofire code.
Have another user saying about issues with controller using psx driver.
http://mametesters.org/view.php?id=6260
The controller is analog xinput and work perfectly without issues with others emulators and previous versions of MAME.
Thanks and God bless. Have an nice day.

User avatar
No.12828
Tafoid
Administrator
Jun 28, 2016, 03:49
We need someone with x-input based controller to be able to duplicate this. Anyone?
User avatar
No.12833
B2K24
Moderator
Jun 28, 2016, 05:20
Easily confirmed as outlined in the report.
User avatar
No.12834
Augusto
Tester
Jun 28, 2016, 07:50
I had used the layout below in my controller
Buttons MAME > Controller
1 > Square
2 > X
3 > R1
4 > Triangle
5 > Circle
6 > R2
Buttons 4,5 and 6 has issues.

Now if using the layout below
Buttons MAME > Controller
1 > Triangle
2 > Circle
3 > R2
4 > Square
5 > X
6 > R1
Not more issues.
The issues is when using buttons 4,5 and 6 in Triangle, circle and R2.

Remember the same detail in the link below
http://mametesters.org/view.php?id=6260
Original Post
``
When the analog is turned on, some input changes in this way:
original input -> (changed to original possition of)
[ ] (square) -> L1
/\(triangle) -> R1
R1 -> /\(triangle)
L1 -> R2
R2 -> [ ] (square)
Other inputs (X, O, L2, start, select, digital pad, analog sticks) aren't messed up.
``

Exactly in my controller the inputs 0, L2, start, select, digital pad and analog sticks not has issues if configurating an MAME button.
My controller is analog. Not has option to disable. Is all time analog.
User avatar
No.12845
B2K24
Moderator
Jun 29, 2016, 19:03
Will set this to acknowledged for now while we can figure this out and determine if there's any connection with 06260
User avatar
No.12859
Augusto
Tester
Jun 30, 2016, 05:17
edited on: Jun 30, 2016, 06:34
Yes has an problem and is recent because the same controller work without problem in previous MAME versions.
0.168 work fine.
Perhaps after that autofire code was added ?
Here is bug even. The issue continue in current 0.175 version.

User avatar
No.13039
Augusto
Tester
Aug 8, 2016, 03:07
Please see the updated post report.
What was the MAME version autofire was added ? I will test.
Thanks.
User avatar
No.13043
Augusto
Tester
Aug 10, 2016, 20:14
edited on: Aug 12, 2016, 15:51
If selecting
# OSD INPUT OPTIONS
#
joystickprovider dinput

The issue is fixed if changing auto to dinput.
If using auto in W10 will be used xinput.
If selecting xinput has problems with my xinput controller in analog buttons.
This configuration above not is in mame docs or frontends.
Perhaps others users will have problems if not changing for dinput.