Viewing Issue Advanced Details Jump to Notes ]
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06107 Core Major Always Dec 27, 2015, 04:27 27 days ago
Tester Robbbert View Status Public Platform MESS (Self-compiled)
Assigned To Robbbert Resolution Fixed OS Windows Vista/7/8 (64-bit)
Status [?] Resolved   Driver
Version 0.168 Fixed in Version 0.185 Build Normal
Summary MESS-specific 06107: any system with a software list: software list problem (see description)
Description Gamate is an example system, this problem happens with any system with a software list. Prerequisite: the system must have its own ini file, and writing must be enabled (as required by messui).

let's start with no cart loaded.

now,
>mame gamate cubeup

cubeup loads and runs in gamate as expected

now,
>mame gamate tornado

cubeup is still there! it starts up and runs. ***Clearly, the ini entry is overriding the command-line entry, which is wrong.***

now,
>mame gamate -cart x

this forcibly unloads cubeup, and the expected error happens. Now we can load tornado.

The command-line entry (if provided), should always override and displace whatever is in the ini.

MESSUI writes the info into the ini file, so the bug doesn't exist there. The problem only happens from the command line.
Steps To Reproduce see description.
Additional Information
Flags
Regression Version
Affected Sets / Systems any system with a software list
Attached Files
 


-  Notes
User avatar
No.12278
Haze
(Senior Tester)
Dec 27, 2015, 09:55
edited on: Dec 27, 2015, 09:56
what is the point in this 'writing' option, and why does it exist in baseline MAME?

i've seen it, but never really understood why it's there, and it does indeed seem to be the source of problems. Maybe the correct fix is the removal of that option?

User avatar
No.12286
B2K24
(Moderator)
Dec 29, 2015, 17:43
I can confirm this behavior but also notice if you empty the slot using the internal UI, you are then able to run the set inserted at the command line.
User avatar
No.12367
Robbbert
(Developer)
Jan 24, 2016, 04:57
Commenting out lines 142 and 145 of clifront.cpp appears to fix the problem.
User avatar
No.13672
Robbbert
(Developer)
Feb 27, 2017, 02:18
Committed a change which may fix it

https://github.com/mamedev/mame/commit/19f34d9cf8107f18e0ef502f5353c1fc594e353f
User avatar
No.13789
Robbbert
(Developer)
27 days ago
This is fixed recently, either by my change or by Nathan's subsequent work. Resolving.