Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06450 Color/Palette Minor Have not tried Dec 10, 2016, 05:24 Dec 10, 2016, 23:27
Tester jeff p View Status Public Platform
Assigned To Robbbert Resolution Fixed OS
Status [?] Resolved Driver astinvad.cpp
Version 0.180 Fixed in Version 0.181 Build
Summary 06450: spcking2: Incorrect colors at certain areas of the screen.
Description The romset "spcking2" incorrectly uses player 2's color scheme from the color versions of Space Invaders during attract mode, and also in gameplay when the first player is up; the color scheme used for the second player depends on whether the game is in upright mode or cocktail mode. The only time the colors are completely correct is in a 2-player game in upright mode when it is player 2's turn. In cocktail mode, the game switches color schemes as it should, but has the color schemes for each player reversed.

In addition, player 2's color scheme is incorrectly being used in 1-player games, as well as the game demo in attract mode.
Steps To Reproduce 1. Start a 2-player game in upright mode (the game is set to upright mode by default). Both players are using player 2's color scheme. (When it is player 2's turn, all colors are correct.)
2. After the game in upright mode is over, set the machine to cocktail mode (the switch is found under "Dip Switches"), and then start another 2-player game. This time, the game switches color schemes as it should when play switches to the other player. However, the color schemes are reversed. In other words, player 1 is using the proper color scheme for player 2, and when it is player 2's turn, the proper color scheme for player 1 appears.
Additional Information This sounds like a repeat of the color issue I reported for the 8080bw driver, but this time, it is specifically for the romset "spcking2", which uses the astinvad driver.
Flags
Regression Version
Affected Sets / Systems spcking2
Attached Files
 
Relationships
There are no relationsihp linked to this issue.
Notes
1
User avatar
No.13470
Robbbert
Developer
Dec 10, 2016, 23:27
The only youtube videos are from emulators, however I found one with the correct colours, so it must have worked at some stage.



Fixed.