Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
04568 Sound Major Always Dec 15, 2011, 21:41 Dec 15, 2011, 22:08
Tester Gae_Mame View Status Public Platform MAMEUI
Assigned To Resolution No change required OS Windows XP (32-bit)
Status [?] Closed Driver
Version 0.144 Fixed in Version Build
Summary 04568: frogger and probably many others: 0.144 runs slow and sound chops on old athlon 1.2 ghz
Description mameui 0.144 runs slow and sound is not good when insert coin and during the game

this appear on windows xp sp3, with athlon 1.2 ghz
Steps To Reproduce install mameui 0.144 (or mame for dos) on old pc with windows xp and athlon cpu running at 1.2 ghz

start frogger game

press key 5 to insert coin

insert coin sound is not good, slow and choppy

start play and see poor fps, crap sound and slow response
Additional Information mameui 0.144 it works perfect on windows 7 sp1 with amd64 dual core cpu

but mame version 0.72 and mame version 0.122 works also perfect on pc with athlon 1.2 ghz

what appens to 0.144 ??
Flags
Regression Version
Affected Sets / Systems frogger and probably many others
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
1
User avatar
No.07971
Tafoid
Administrator
Dec 15, 2011, 22:07
edited on: Dec 15, 2011, 22:07
Gae,

The driver (galaxian) has been rewritten since that version you mentioned (0.122) and takes more horsepower to present it as accurately as possible in the newer versions. This includes, but is not limited to, video changes (more to do) as well as discrete sound filtering additions (more to do). Combine all that together core, memory and other issues that keep the emulation going and that only means one thing.. your ATHLON 1.2gz Thunderbird (which you yourself termed as an "old pc" above) is too slow now to run current MAME for that game.

If you must use that machine, you have to use an older version more suited to it. Expecting a decade+ old processor to play the same things with versions of MAME that were released nearly 4 years apart is not logical and is not grounds for submitting a bug report.

Closing.