Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07201 Sound Minor Always Jan 6, 2019, 18:38 Jan 11, 2019, 17:44
Tester Hydreigon View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Acknowledged Driver namcos22.cpp
Version 0.205 Fixed in Version Build 64-bit
Summary 07201: tokyowar: [possible] Startup sound/jingle doesn't properly play.
Description When the game starts up, it will play a "Tokyo Wars" voice clip and then a little jingle right afterwards. Currently, there is a timing related issue that only a small portion of that sound file will play. Whatever part of that sound file plays is different. I have gotten it to say "Wars" only and after clearing the cfg and nvram files, now it plays a small portion of the jingle.

Steps To Reproduce Launch/reset the game.

(From addition information): Go into test mode and go into sound test and press the gas pedal. It will play the full sound file, labeled "Good Morning Fighters".
Additional Information The sound file itself works if one goes into test mode and plays that file via the sound test, labeled "Good Morning Fighters". In earlier versions, it would play most of that startup sound/jingle and cuts at the very last note. This however has been the case ever since the game has been added to Mame.
Flags Possible
Regression Version 0.205
Affected Sets / Systems tokyowar
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
1
User avatar
No.16015
hap
Developer
Jan 6, 2019, 19:27
Do you have a reference of the pcb bootup? If not, this bug should be set to "possible".
MB87078 (volume controller) was hooked up to the SS22 driver recently. This device initial state is maximum volume output. At boot, the game purposely sets all channels to 0 volume.

see log (channel, volume)
initial reset state: 3 100, 2 100, 1 100, 0 100,
POST(power on self test) screen: 0 0, 1 0, 2 0, 3 0,
namco logo: 0 30, 1 30, 2 47, 3 20,