Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07656 Known Issues/To-Do's Minor Always May 13, 2020, 08:26 Jun 24, 2020, 18:53
Tester d18c7db View Status Public Platform MAME (Official Binary)
Assigned To hap Resolution Fixed OS Windows 10 (64-bit)
Status [?] Resolved Driver atarisy1.cpp
Version 0.220 Fixed in Version 0.222 Build 64-bit
Summary 07656: Atari System1 bad ROM dumps: Atari System1 bad ROM dumps (TTL and LSI)
Description Two Atari BIOS ROMs have bad dumps.

1) ROM 136032.107.b2 CRC(315E4BEA) from LSI PCB has top nibble of every byte set to zero. The fix for this is easy, this ROM should be a dupe of ROM 136032.104.f5 CRC(7A29DC07)

2) ROM 136032.105.l13 CRC(690B37D3) from TTL version 1 is a bad dump (entire file is FF)
Steps To Reproduce 1) mame64.exe -debug -bios 2 indytemp
Immediately on title screen, the text colors at top and bottom of screen are wrong. This is due to top nibble on ROM B2, feeding zeroes to the 4 bit shifter that generates APIX1 line towards the GPC (in schematic), so the line is stuck low. Using ROM F5 fixes this.

2) mame64.exe -debug -bios 1 indytemp
Game fails to run because this ROM provides the upper data byte for the the 68010 processor instruction words. CPU fails to execute properly.
bios 0 and bios 2 are OK. A fresh/good ROM dump is needed for 136032.105.l13.
Additional Information
Flags
Regression Version
Affected Sets / Systems Atari System1 bad ROM dumps
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
1
User avatar
No.17648
hap
Developer
May 13, 2020, 13:52
It looks like the correct rom dumps were already around.