Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07761 Save/Restore Major Always 24 days ago 21 days ago
Tester rcoltrane View Status Public Platform MAME (Official Binary)
Assigned To Resolution No change required OS Windows 10 (64-bit)
Status [?] Closed Driver snk.cpp
Version 0.223 Fixed in Version Build 64-bit
Summary 07761: ikarijp: INP playback out of sync
Description Tried to playback my ikarijp 1cc run to record an .avi video but the playback went out of sync.
Steps To Reproduce Record a full gameplay to the end and try to playback it right after. It will go out of sync after some time.
Additional Information The .inp system seems to be very unstable lately, many of my 1cc runs were lost due to out of sync problems, very frustrating.
Flags
Regression Version
Affected Sets / Systems ikarijp
Attached Files
? file icon ikarijp.inp (331,879 bytes) 24 days ago Uploaded by rcoltrane
ikari 1cc run mame 0.223 64bit win10
Relationships
There are no relationship linked to this issue.
Notes
7
User avatar
No.18009
Tafoid
Administrator
24 days ago
I'm still not convinced here that it is something you've either set as a command, and input or video scheme, or something else that isn't default that is causing an issue with .inp. I did a rather small play (not very good at this game at all), but made it past the location where you input file fails on my end (that first big boulder in the center of the screen) and it played back to game end and "Playback Ended" popup.

Any reason you are not using the latest 0.224 (soon to be 0.225 in a couple days)?
Are you positive you are using the MAME from mamedev.org and not MAMEUI or some other derivative?

I'd only suggest you try to -record a game with as little changed to any MAME settings as possible.
I'm curious, did you test my .inp I uploaded for nrallyx on your setup? Does it finish to the round and score I reported?

Anyway, I can confirm your issue only based on your record uploaded, not by my attempts to duplicate.
User avatar
No.18010
rcoltrane
Tester
24 days ago
edited on: 23 days ago
Of course I'm using the original MAME from mamedev! No problem at all, I will update as soon as MAME 0.225 comes.

I'm using Launchbox to just 'launch' my games using some command line parameters, nothing extremely fancy or unusual. A bunchload of games works fine with inp files, but a bunch of them do not work as expected (see my kchampvs3 / nrallyx / renegade / indytemp reports here) It playbacks here as well with no issues for a couple of minutes, but after some time, it goes out of sync. To properly test it you need to do a longer gameplay though.

Someone told me at my Renegade report (I think) that the .inp system needs a major rewrite to work properly.

EDIT: tested it with latest 0.224 and it gives the same results. So, I think it proves that the .inp system is indeed not realiable at the moment, unfortunately. I will stop reporting these pointless .inp bugs.
User avatar
No.18012
Tafoid
Administrator
22 days ago
No. I'd rather you continued to report things if you see issues. Latest as of right now is 0.225 as it was just released hours ago.
If you really want to figure out what might be causing the issue, I will need your help to provide information and help diagnose all possible causes of malfunction. Frankly, I'm still not convinced that Launchbox isn't inserting command(s) which may be causing the malfunctions either directly or indirectly.
Something as simple as using a non-default input via -joystick_provider or something else could be causing it.

First off, are Launchbox's settings automatically saved in MAME.INI or does the program have a listing of exactly what it is sending (or stored elsewhere)? Can you capture this and upload the text. Please post your launch string if at all possible.

I'd also like to see the following:
mame.ini contents (upload file is fine) and the output of this command:
> mame64 -verbose -showconfig > configuration.txt
uploading that "configuration.txt" output.

When I can see exactly what your front-end is sending/what your settings may be, we can work on eliminating any suspects that might be interfering with .inp -record (and resulting -playback).
User avatar
No.18015
rcoltrane
Tester
21 days ago
My setup does not have a MAME.ini file anywhere. And Launchbox allows you to customize your command line for each game, here's my ikarijp command line parameters, please see if there's something that could interfere with the inp recording/playback:

-bgfx_backend opengl -bgfx_screen_chains crt-geom-deluxe-HACKVERT -bgfx_shadow_mask -noreadconfig -nowriteconfig -nofilter -triplebuffer -pause_brightness 1.00000000 -cheat -nonvram_save -plugin hiscore -skip_gameinfo -noui_mouse -rompath "C:\RCS\Games\UME\roms\ARCADE" -aviwrite ikarijp.avi -nosnapbilinear -video bgfx
User avatar
No.18017
Tafoid
Administrator
21 days ago
Take out the -plugin hiscore trigger (and potentially -cheat as well) when doing recordings or playbacks.
In my testing dropping the plugin this fixed the playback of my file which was crashing out hard on the that command-line trigger list you posted.

At this point I'd have to assume most/all of the issues you've had with recording is regarding the hiscore plugin.
Please retest locally and let us know.
User avatar
No.18021
rcoltrane
Tester
21 days ago
I did some major cleanup here after updating to latest mame 0.225.

I had a lot of old .ini files that were not being used anymore and so I erased all these .ini files (I'm handling everything through LaunchBox now). I've also erased all my old .inp files too. After that, I did some more tests with nrallyx and ikarijp and, to my surprise, both are recording/playbacking fine now! I did a somewhat long recording in both of them and both playbacks worked fine to the end. And I didn't need to remove the hiscore plugin and/or cheats as you suggested.

So I suppose that the trouble has no relation to the cheat system and/or hiscore plugin, but it may has relation to the old .ini/.inp files I had that were recorded/generated by old mame versions.

With that said you can now close all these .inp bugs I reported here beacuse it seems that the .inp system is working fine.
User avatar
No.18025
Tafoid
Administrator
21 days ago
One of your .ini files appears to have had plugins activated making the -plugin hiscores work where it doesn't work if if plugins is set to 0 or -noplugins is set as high scores would not load or save. In any case, we are going to not suggest either -cheat or -plugin hiscore be active when recording/playing back an .inp file.

I am relieved that the issue seems resolved on your end in any case. I will close the recent reports.