Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
08009 Graphics Minor Always Jun 16, 2021, 05:55 Jun 17, 2021, 10:44
Tester Osso View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Confirmed Driver namcos2.cpp
Version 0.232 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 08009: finallap and clones, finalap2 and clones: At title screen, the background should fade to black. It only dims instead
Description As shown in
&t=219s the background should fade to black while the title screen appears. In MAME it only gets a bit darker.
Final Lap 2 should behave the same, though in this case the video only shows the background already black:
Steps To Reproduce Just let the attrace mode run
Additional Information Reported by Guru, who says his Final Lap 2 PCB shows the black background on title screen.
Github Commit
Flags
Regression Version
Affected Sets / Systems finallap and clones, finalap2 and clones
Attached Files
png file icon 0000.png (8,015 bytes) Jun 16, 2021, 05:55 Uploaded by Osso
Final Lap title screen in MAME 0.232
Osso
png file icon 0001.png (10,179 bytes) Jun 16, 2021, 05:56 Uploaded by Osso
Final Lap 2 title screen in MAME 0.232
Osso
jpg file icon finalap2_pcb.jpg (560,047 bytes) Jun 16, 2021, 16:01 Uploaded by Osso
Final Lap 2 title screen on PCB with brightness turned up
Osso
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.18990
Osso
Developer
Jun 16, 2021, 16:01
After further verifying by Guru, if the brightness is turned *way* up, the background is visible even on PCB (see attached finalap2_pcb.jpg). So it's possible the default brightness is very low (both Guru and the linked videos seem to confirm this).
User avatar
No.18994
Haze
Senior Tester
Jun 17, 2021, 10:44
edited on: Jun 17, 2021, 10:45
this and the overly bright image in final lap in general seem like a gamma problem. Arcade monitors did generally display darker, we see this with a lot of Capcom games, the 'grey boxes' issue in emulators, but it's a little surprising to see it here because as fas as I know the other Namco System 2 games seem to have relatively normal looking output levels.

how are the colours generated on the Final Lap boards? is there a resistor network that differs to the other Sys2 games that could result in darker overall colours, or is it maybe just a monitor adjustment thing given they were used in dedicated cabs.