Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
08351 Interface Major Have not tried 20 days ago 18 days ago
Tester chijb55 View Status Public Platform MAME (Official Binary)
Assigned To Resolution Unable to reproduce OS Windows 10/11 (64-bit)
Status [?] Closed Driver centiped.cpp
Version 0.244 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 08351: centiped: Mouse/Trackball no longer responds in Centipede (but works in Windows and other games)
Description Updated to MAMEUI v.244. All games seem to be working fine, except Centipede. Centipede now only works with joystick control, and doesn't respond to mouse/trackball at all.

Other games using trackball (ie Golden Tee, etc) work fine.

Mouse and trackball works fine in Windows 10 as well.

All Windows drivers up to date. Tried deleting mame.ini as well as centiped.cfg, but no change.

When I went back to 0.238, the problem went away.
Steps To Reproduce Run MAME.
Start "Centipede"

*TAB to pull up options.
*Input This Machine
*Track X Analog
*ENTER to choose input
Move mouse or trackball left/right. No input is detected.

May affect other games, but so far I've only seen this behavior in CENTIPEDE.
Additional Information
Github Commit
Flags
Regression Version 0.238
Affected Sets / Systems centiped
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.20314
Steve Coomber
Tester
19 days ago
I have just tried running Centipede on the latest MAME and MAMEUI (both 0.244) and experienced no issues with mouse or trackball.
User avatar
No.20317
Tafoid
Administrator
19 days ago
edited on: 19 days ago
You also mentioned using MAMEUI - please verify issues happen in the released integer version of MAME from mamedev.org. MAMEUI bug are not to be reported here. You will need to make sure you activate the MOUSE in your mame.ini, use -mouse from command-line, or in the MAME's internal UI itself:
Configure Options -> Advanced Options -> Scroll down to Input Options and find "mouse" and turn that "On"
Save configuration and you should be all set.
Tested and it works perfectly fine here.