Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
08352 Sound Minor Always 19 days ago 18 days ago
Tester ICEknight View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10/11 (64-bit)
Status [?] Confirmed Driver gba.cpp
Version 0.244 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary MESS-specific 08352: gba [gwatch4 and clones]: Audio channel missing (or very low?)
Description One of the audio channels seems to be missing in the Title Screen of Game & Watch Gallery Advance/4.

Original hardware behavior:


MAME 0.244 and earlier:


Other games which may be affected by the same bug:
-Bomberman Tournament: Intro.
-Bubble Bobble Old & New: Game Over in "Old" mode.
-Sonic Advance: Second level.
Steps To Reproduce Just load the game.
Additional Information
Github Commit
Flags
Regression Version
Affected Sets / Systems gba [gwatch4 and clones]
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.20318
Tafoid
Administrator
19 days ago
Is this a regression in function?
All the gameboy emulations have functional but imperfect sound and are flagged as such.
If you could stick to a specific instance and give us a recording of original vs. emulated perhaps something can be done about this.

For instance, sound improved as recently as 0.242 which fixed a long standing issue. Sound regressed originally on 0.179 so 0.178 and earlier may have improved sound? Can you compare that to how it is supposed to sound and make some comparison audio recordings?
User avatar
No.20320
ICEknight
Tester
18 days ago
edited on: 18 days ago
It's also missing in 0.178 (and the working sound channels sound better after the 0.242 fixes), so not a regression.

I've added a recorded video of the latest version.