Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
01875 Crash/Freeze Critical (emulation) Random Jun 6, 2008, 17:13 Jun 8, 2008, 23:49
Tester Scagazza View Status Public Platform MAME (Self-compiled)
Assigned To Resolution Suspended OS Windows XP/Vista 64-bit
Status [?] Closed Driver zr107.cpp
Version 0.125u4 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 01875: midnrun: Game freeze
Description The game freezes during initial test screen, there is an error as you can see in the image or hangs after the logo.
Steps To Reproduce
Additional Information
Github Commit
Flags
Regression Version
Affected Sets / Systems midnrun
Attached Files
png file icon 0000.png (4,396 bytes) Jun 6, 2008, 17:13
Relationships
There are no relationship linked to this issue.
Notes
7
User avatar
No.01206
aaron
Developer
Jun 6, 2008, 17:51
Works fine here. You must be compiling your own. What options are you using and what version of MSVC. I suspect a compiler bug.
User avatar
No.01209
Scagazza
Tester
Jun 6, 2008, 17:59
MSVC 2008 MSVC_BUILD=1 PTR64=1 without changing the makefile
User avatar
No.01210
Haze
Senior Tester
Jun 6, 2008, 19:12
konami nvram? ...
User avatar
No.01211
Tafoid
Administrator
Jun 6, 2008, 19:40
Doesn't repro for me on 32-bit. The EEPROM is initialized automatically (checks steering and other inputs.. then prints "EEPROM INITIALIZE COMPLETE" message)
User avatar
No.01213
Canim
Senior Tester
Jun 7, 2008, 11:36
It's the complete driver zr107.c. All games suffer by the same problem. You have to restart mame and all games work. Running a game for a 2nd time gives me always a bad rom. But the best thing is now mame does not crash for me anymore like in 01677. Now the driver seems to work for 64bit.
User avatar
No.01229
robiza
Developer
Jun 8, 2008, 09:08
the bug is:
in every zr107 game, the reboot with a f3 reset hangs in initial test screen

this report can be closed and a new general report can be created
User avatar
No.01241
Fujix
Administrator
Jun 8, 2008, 23:49
I close this report.
As everybody assumes above, the current condition is "working" for us.
Of course the game doesn't have a flag but the emulation is clearly incomplete.

Flag is not everything, please try to take into account the status of the driver from various source including what'snew.