Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
03110 Crash/Freeze Critical (emulation) Have not tried Apr 19, 2009, 17:59 Apr 23, 2009, 22:39
Tester Luigi30 View Status Public Platform MAME (Self-compiled)
Assigned To Resolution Fixed OS Windows XP/Vista 32-bit
Status [?] Resolved Driver meritm.cpp
Version 0.130u4 Fixed in Version 0.131 Build Normal
Fixed in Git Commit Github Pull Request #
Summary 03110: megat4st: Fails to boot with a "Key Question Set Error"
Description megat4st hangs on bootup with a screen saying Key Question Set Error. The contents of the Dallas SRAM aren't in the driver, so the game refuses to boot.
Steps To Reproduce
Additional Information
Github Commit
Flags
Regression Version 0.130u3 (added)
Affected Sets / Systems megat4st
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
3
User avatar
No.04222
Tafoid
Administrator
Apr 19, 2009, 18:16
edited on: Apr 19, 2009, 18:42
Not sure what the issue is - but it's likely the game was not added to the driver correctly and might be missing or using the wrong initialization code. People should make sure, when added, that those clones/alternate versions work correctly. If not, they should be appropriately labeled until someone can figure it out.
User avatar
No.04223
Luigi30
Tester
Apr 19, 2009, 20:31
edited on: Apr 19, 2009, 20:32
Looking at the driver, whoever added the set didn't add the security key contents for it.
User avatar
No.04257
Luigi30
Tester
Apr 23, 2009, 22:35
The key was silently added in .131 and it boots now.