Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
03799 Graphics Minor Always Mar 28, 2010, 20:07 Jun 7, 2021, 10:38
Tester Tafoid View Status Public Platform MAME (Self-compiled)
Assigned To Resolution Open OS
Status [?] Confirmed Driver junofrst.cpp
Version 0.137u1 Fixed in Version Build
Fixed in Git Commit 1de6fab Github Pull Request #
Summary 03799: junofrst: Credit during demonstration play causes graphic error
Description This is an interesting one. When you credit while the gameplay demonstration is happening, the credit/title screen's logo gets cut off on the right side. What's even weirder is that it doesn't happen with the gottlieb version of Juno First (junofrstg).
Steps To Reproduce
Additional Information I was able to test early mame versions and found a regression version - 0.33u6
Both 0.33u5 and 0.33u6 snaps are included.
Github Commit
Flags
Regression Version 0.33b6
Affected Sets / Systems junofrst
Attached Files
pcx file icon JUNOFRST-0.33b5.PCX (13,289 bytes) Mar 29, 2010, 01:39
pcx file icon JUNOFRST-0.33b6.PCX (13,301 bytes) Mar 29, 2010, 01:39
gif file icon Animation1.gif (4,699 bytes) Mar 29, 2010, 05:26
Relationships
related to 07992Resolvedgalibert  junofrst: No screen colour change during key actions 
Notes
8
User avatar
No.05923
Haze
Senior Tester
Mar 28, 2010, 20:20
I wouldn't be surprised if this was a real game bug, especially given that it only happens on one version. They could also have coin lockout enabled in attract mode (if it isn't already hooked up) but that would be somewhat illogical.
User avatar
No.05925
M.A.S.H.
Senior Tester
Mar 29, 2010, 05:27
edited on: Mar 29, 2010, 05:48
Added an animated GIF. The regression version (MAME 0.33beta6) is
correct. I checked it with DOSBox. The bug was not in MAME 0.33b5!
User avatar
No.05927
stephh
Developer
Mar 29, 2010, 10:59
From src/mame/video/tutankhm.c.html :

TODO: Does bit 1 of the source address mean something?
      We have to mask it off otherwise the "Juno First" logo on the title screen is wrong.

And indeed is the "copy" flag only based on bit 0 :

int copy = state->blitterdata[3] & 0x01;

It would be interesting to see the difference in the code between the 2 sets as GFX1 is the same.
User avatar
No.05942
robiza
Developer
Apr 5, 2010, 08:46
edited on: Apr 5, 2010, 08:47
it's a timing problem

the interrupt draw the "juno first" logo before the screen is clear; at the end of the interrupt the "clear screen routine" continue and delete the last
part of the logo

MDRV_CPU_ADD("maincpu", M6809, 1500000) /* 1.5 MHz ??? */

with a higher value the bug disappear
we need to know the exact clock
User avatar
No.05943
M.A.S.H.
Senior Tester
Apr 5, 2010, 09:19
PCB info says for 2x Juno First bootlegs 1x oscillator 18.432 = 18432000 Hz.
If the factor is 12, then
18432000/12 = 1.536 MHz
User avatar
No.05950
robiza
Developer
Apr 6, 2010, 10:31
it's necessary a PCB; maybe Tutankhamon use a very similar PCB
User avatar
No.18933
Haze
Senior Tester
Jun 7, 2021, 10:02
This still happens.
User avatar
No.18935
Tafoid
Administrator
Jun 7, 2021, 10:38
When I tested I could have sworn it was fixed in that era - I'll have to check if/when it re-regressed.
Unresolved for now.