Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06319 DIP/Input Major Always Jul 21, 2016, 19:50 13 days ago
Tester Fortuna View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Confirmed Driver gticlub.cpp
Version 0.175 Fixed in Version Build 64-bit
Summary 06319: gticlub and clones: Accelerator don't work and message appear in screen
Description Load, wait the initial tests, error appear when, this not happen in older versions

The accelerator control don't respond in game
Steps To Reproduce
Additional Information
Flags
Regression Version
Affected Sets / Systems gticlub and clones
Attached Files
png file icon 0000.png (4,569 bytes) Jul 21, 2016, 19:50 Uploaded by Fortuna
Fortuna
Relationships
There are no relationship linked to this issue.
Notes
8
User avatar
No.12967
Osso
Developer
Jul 24, 2016, 05:22
The steering wheel error has been there for a long time: I checked back to 0.130 and it was there.
The accel error I cannot reproduce and it works in game too.
User avatar
No.12974
Kale
Developer
Jul 26, 2016, 10:43
What happens if you try to calibrate it thru Test Mode?
User avatar
No.12975
Fortuna
Tester
Jul 27, 2016, 00:04
edited on: Jul 27, 2016, 00:04
Do not respond when the button is pressed too

Trying:

-Reset the machine
-Clear the nvram (F2+F3 inn start)
-Deleting the *.nv created for new file

Always has this screen (is next to calibration screen), in older versions working ok, bit a bit less performanced
User avatar
No.12977
Tafoid
Administrator
Jul 27, 2016, 04:15
Please refer to my note at 06325 - default mapping with a fresh install doesn't act like you have mentioned.
Try a fresh install on your end without mapping anything and see how that works. I suspect you have some controller condition that is causing conflict and the the game is looking and determining your pedal mapping is down all the time.
User avatar
No.12989
Fortuna
Tester
Jul 27, 2016, 22:01
Well, testing with new and clear config, the problem continue
User avatar
No.13866
Fortuna
Tester
Jun 2, 2017, 01:31
**Update**

Testing in .185 version and using 2 differents joysticks and keyboard:

Test 1: Xbox 360 joystick with wireless reciever, deleted cfg and ini configs, all clear only detect this joystick: Steering wheel error

Test 2: Generic 8 buttons 4 axis USB joystick model Genius Maxfire G-08XU, Clear config, deleted cfg and all ini for default, only this joystick detected, the games boots and the message "Steering wheel error" not appear, runs perfectly

Test 3: Keyboard with usb reciever, model Logitech, same above, Runs ok, but if the Xbox 360 joystick is detected, this has the message "Sterring wheel error" appear
User avatar
No.15747
MetalGod
Tester
15 days ago
edited on: 13 days ago
Tested with a logitech G27 Steering Wheel. It marks 2 errors:
Device Error (Steering Wheel)
Device Error (Brake)

Once ingame the steering wheel works, the brake doesn't.
I figured out how to solve this. It is neccesary to mark "combined pedals" option inside the g27 wheel settings. Then, configuring mame keys for accelerator and brake. Now they both will appear marked as "combined pedals".
The only error the game will show in its startup will be the one for the steering wheel. Once ingame everything works fine, steering wheel, accelerator, brake...

It is pretty weird because gti club is the only mame racing game where I've had to enable that option.
User avatar
No.15767
Hydreigon
Tester
13 days ago
The culprit lies within adc1038.cpp, National Semiconductor ADC1038. Only GTI Club has a hack in that device for its analog controls to function because it doesn't sync on sars. The best fix would be to improve on that device and remove the hack for good but idk how much work that would take.

Come to think of it, this may be related to why Silent Scope's analog controls work in test mode but not ingame (Ted probably should have leaved my Silent Scope bug as confirmed and make these two bugs related). It does use a different semiconductor, ADC12138, but both issues are related to sync/cycles ingame.