Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
06434 Sound Trivial Have not tried Nov 22, 2016, 10:54 18 days ago
Tester Fujix View Status Public Platform
Assigned To Resolution Open OS
Status [?] Confirmed Driver nemesis.cpp
Version 0.179 Fixed in Version Build
Fixed in Git Commit Github Pull Request #
Summary 06434: twinbee, nemesis, gwarrior: Better sound proportion
Description RC Filter 1: 1.30 (twinbee, gwarrior), 0.7 (nemesis)
RC Filter 2: 0.60 (broken in gwarrior)
RC Filter 3: 0.45
RC Filter 4: 0.55
K005289 SCC: 0.45
VLM5030: 1.40

This doesn't eliminate SFX clippings.
Steps To Reproduce
Additional Information
Github Commit
Flags
Regression Version
Affected Sets / Systems twinbee, nemesis, gwarrior
Attached Files
 
Relationships
child of 03539Confirmed  nemesis, gradius, nemesisuk: Sound reproduction issues. 
Notes
9
User avatar
No.13419
Robbbert
Developer
Nov 24, 2016, 03:27
fixed typo
User avatar
No.13420
Fujix
Administrator
Nov 24, 2016, 04:11
Thank you.
User avatar
No.13423
Tafoid
Administrator
Nov 25, 2016, 00:59
Does this setting also improve gradius? The "gx400" machine state is shared between 3 machines currently (Galactic Warriors, Gradius (not Nemesis?) and Twinbee)
User avatar
No.13426
Fujix
Administrator
Nov 25, 2016, 03:51
Worked out new values for all GX400 games, but they still have SFX clippings especially in Gradius. They are caused by the filters.
User avatar
No.13429
Fujix
Administrator
Nov 27, 2016, 01:51
Filter 1 plays the main part of the music in Twinbee, but plays SFX in Graidius, they take clearly different volume in each game.
And in gwarrior, the Filter 2 is broken and keeps output noisy loop sounds.
User avatar
No.19655
haynor666
Tester
20 days ago
Not sure if this is fixed with many changes. If someone could post pcb recording would be nice.
User avatar
No.19663
Fujix
Administrator
20 days ago
This report is old and needs revalidation.
User avatar
No.19664
Fujix
Administrator
20 days ago
Here's a real Gradius of the Bubble System version.
User avatar
No.19670
Ace
Tester
18 days ago
This relates to an issue I reported in 2014 pertaining to incorrect AY-3-8910 load resistance: https://mametesters.org/view.php?id=5438
The fact the AY-3-8910's outputs are emulated with the default 1K load resistance completely throws off the volume scale since the PCB doesn't use any load resistors on either AY-3-8910. This might need full discrete emulation as mentioned by AWJ in the replies to get the audio balance right.