Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07161 Sound Minor Always Nov 27, 2018, 13:57 9 days ago
Tester StHiryu View Status Public Platform MAME (Unofficial Binary)
Assigned To Resolution Open OS Windows Vista/7/8 (64-bit)
Status [?] Confirmed Driver dec0.cpp
Version 0.203 Fixed in Version Build 64-bit
Summary 07161: baddudes: Missing sound in stage 3 boss transformation
Description At the stage 3 boss, when the green ninja transforms into multiple ones, he says some japanese words and then starts to split. After those words a sound effect should be played.

Discovered after checking a repaired pcb video on youtube, but I'm not sure if that pcb is the USA version or a bootleg. Anyone has a US pcb to compare?
Steps To Reproduce Fight against stage 3 boss and hit him until he transforms.
Additional Information -Recorded video from mame (min 6:24):


-Video from arcade pcb (min 8:36):


-Another video pcb but barely audible, (however I can hear the effect at 6:10):
Flags Verified with Original
Regression Version 0.57
Affected Sets / Systems baddudes
Attached Files
zip file icon baddudes.zip (6,497 bytes) Nov 27, 2018, 14:40 Uploaded by MetalGod
Relationships
There are no relationship linked to this issue.
Notes
11
User avatar
No.15846
MetalGod
Senior Tester
Nov 27, 2018, 14:39
edited on: Nov 27, 2018, 14:41
I can confirm it ocurrs in last mame version: 0.203
Uploaded savestate
User avatar
No.16338
StHiryu
Tester
Apr 16, 2019, 17:29
Taking a look to report 01066, maybe this issue is related to it?
User avatar
No.16820
MetalGod
Senior Tester
Aug 29, 2019, 17:48
edited on: Aug 29, 2019, 18:20
Still happening in mame 0.212

I have recorded this video in an arcade club called Arcade Vintage, placed in Ibi, Spain. Thanks to Jose Maria a member of this club, who assisted me in opening the game cabinet and recording the video while I was playing.
The missing sound in mame can be heard in 0:03 and 0:19
The game pcb can be seen in 0:40
Removing "possible" flag, adding "verified with original"
User avatar
No.17747
MetalGod
Senior Tester
Jun 15, 2020, 15:10
clearer pcb recording here:
User avatar
No.17908
Augusto
Tester
Aug 25, 2020, 11:18
I confirm the missing sound fx was played in MAME several previous versions.
I not remember what is the version perhaps 0.55, 0.66, 0.92, 0.107 and some others.
The sound fx was played in volume very low was need to adjust the volume channel to be close match with arcade.
About https://mametesters.org/view.php?id=6930 perhaps the sound fx in Robocop was played also in previous versions.
User avatar
No.17909
MetalGod
Senior Tester
Aug 25, 2020, 15:55
Augusto, could you, at least, confirm one version where the bug is not present?
User avatar
No.17914
Augusto
Tester
31 days ago
edited on: 30 days ago
Unhappily I not remember exactly what version the sound fx was played :(
The version is before of 2011.
I had used the version 0.55, 0.66, 0.92, 0.107 and few updates before of any version in the year of 2011.
I remember correctly the sound fx in arcades and in MAME the sound fx volume was very low that I allways had adjusted to an value more close to arcade.
I remember the sound fx is played by YM2203.
Another game with problems in YM22003 is rranger
https://mametesters.org/view.php?id=5972
In second stage have an sound fx being played wrong.
Unhappily in moment not having enough time to test what is the version and here using Linux being more hard to test MAME previous versions :(
User avatar
No.17917
Mamesick
Senior Tester
29 days ago
Regression is 0.57 (!!)
from whatsnew of 0.57 there's this which is surely the cause:
- SSG EG type support added to YM2203 emulation (which is now complete).
  This fixes hbarrel wave sound on start of level 1, and some sound effects in
  other games (e.g. Dark Seal). [Jarek Burczynski]
So this fixed some things but broken others, like the sound effect here and robocop van sound.
Feel free to test by yourself, in 0.56 all is fine, in 0.57 there's no sound effect.
User avatar
No.17919
StHiryu
Tester
29 days ago
The robocop van sound it is not exactly the same problem, since it can be solved adjusting the cpu clock...
User avatar
No.17921
Augusto
Tester
28 days ago
edited on: 28 days ago
@Mamesick
You are saying baddudes sound fx is played correctly in 0.55 and 0.56 ?
User avatar
No.17986
StHiryu
Tester
9 days ago
edited on: 9 days ago
I can confirm that baddudes fx plays well in mame 0.56. Also I noticed there is an extra key stroke at the intro sequence that is missing in current mame version, just at the very beginning of the game. The regression version is 0.57, but that key stroke from the intro is still there...
EDIT: That last key sound is not present in several pcb videos on youtube like this:


The robocop van bug has nothing to do with this one. Is a timing issue and plays bad in 0.56 and 0.57.