Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07215 Graphics Minor Always Jan 29, 2019, 11:50 Jan 29, 2019, 16:15
Tester haynor666 View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows Vista/7/8 (64-bit)
Status [?] Confirmed Driver ssv.cpp
Version 0.205 Fixed in Version Build 64-bit
Summary 07215: survarts: Some background graphics are misplaced
Description Some background graphics from time to time are incorrectly placed on screen.
Steps To Reproduce
Additional Information
Flags
Regression Version
Affected Sets / Systems survarts
Attached Files
png file icon survarts0008.png (28,955 bytes) Jan 29, 2019, 11:50 Uploaded by haynor666
haynor666
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.16087
Tafoid
Administrator
Jan 29, 2019, 14:50
Has happened for a long time (tested 0.120 and it still showed, but we used to have graphic imperfect flag on the driver).
So, this was promoted (flag taken off) too soon, it looks like.
User avatar
No.16088
Haze
Senior Tester
Jan 29, 2019, 16:15
edited on: Jan 30, 2019, 12:13
yeah, it's not 'misplaced' as such either, just one layer lagging behind the other. They probably need some kind of software controlled buffering implemented, the smaller sprites are out of sync with the larger tilemap sprites, so likely part of the list gets buffered based on a CPU trigger.

the SSV video was missing many features until I did recent work on it, but I have noticed in the majority of games they do appear to need the regular sprites buffering by a frame in many cases, but I haven't found an appropriate trigger, and it doesn't seem automatic.

further driver improvements are still on my todo list tho.