Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07245 Misc. Critical (emulation) Always Feb 28, 2019, 05:29 Mar 8, 2019, 16:08
Tester ArcadeGuy View Status Public Platform Other
Assigned To Resolution Unable to reproduce OS Windows Vista/7/8 (32-bit)
Status [?] Closed Driver cps1.cpp
Version 0.207 Fixed in Version Build 32-bit
Summary 07245: wofj: Works but with black screen
Description Works but with black screen
Steps To Reproduce load the game
Additional Information
Flags
Regression Version
Affected Sets / Systems wofj
Attached Files
txt file icon verbose.txt (14,340 bytes) Mar 2, 2019, 20:37 Uploaded by ArcadeGuy
[Show Content]
Relationships
There are no relationship linked to this issue.
Notes
20
User avatar
No.16181
B2K24
Moderator
Feb 28, 2019, 09:16
The game plays fine for me.

You might want to try different video modes... (-video bgfx, -video d3d, -video opengl)
User avatar
No.16182
MetalGod
Senior Tester
Feb 28, 2019, 09:44
No problem here too.
Try a clean mame installation.
User avatar
No.16185
ArcadeGuy
Tester
Feb 28, 2019, 19:56
ho i checked again this seems to happen on japanese version only
User avatar
No.16186
B2K24
Moderator
Feb 28, 2019, 20:03
You're right it seems. Confirming...
User avatar
No.16187
Osso
Developer
Feb 28, 2019, 20:30
wofj works normally here, both with 0.207 and with current master.
User avatar
No.16188
Tafoid
Administrator
Mar 1, 2019, 00:41
edited on: Mar 1, 2019, 01:02
No repro on wof, wofj or any clones.
I can only conclude you are seeing some crash due to cheat usage - as the older cheat packages have an issue with this game.

Can you confirm without any cheats and in a fresh install without referencing any cheat data or even using Save States/autosave?
User avatar
No.16190
Robbbert
Developer
Mar 1, 2019, 02:35
Works here.

If you're saying it crashes, where's the error dump or message? There's nothing to work with here.
User avatar
No.16192
ArcadeGuy
Tester
Mar 1, 2019, 16:13
edited on: Mar 1, 2019, 16:18
crashes? but I didn't put crashes at first somebody edited my report and changed it to ''crashes after ok''
what I put here was ''Black Screen'' when you load the game you can't even see the ok or nothing is just a plain black screen you can hear sounds if put a credit and even play a normal game but the screen is full black. also, I wasn't using any cheat or save states I just downloaded mame 207 and this happened I think this happens since mame 206

that was it...
User avatar
No.16193
Tafoid
Administrator
Mar 1, 2019, 16:34
ArcadeGuy:
Your bug data you entered makes it unclear what build you are using in the first place of MAME 0.207 - so I would make sure you try MAMEDEV.org supplied 0.207 for your Windows machine from https://www.mamedev.org/release.html in a fresh folder and try again.

- You've tried running different video modes as suggested in the first note?
- Are you starting it from within the Internal Menu, or are you launching it via command-line? mame wofj -window
- Not sure what else to suggest. In a default state without any influencing configuration files, the game works fine via command-line and in my tests also using the internal UI selection to launch it.
User avatar
No.16194
Hydreigon
Tester
Mar 1, 2019, 16:54
Going to have to agree with ArcadeGuy on this one but I have yet to see if I can reproduce this issue. If he never said anything about crashing, then why the unnecessary change in the description and summary? The game is supposed to ok and then the black screen occurs on an issue like this (it's as if the game plays blind). Sorry for the confusion from the unnecessary changes.
User avatar
No.16195
Tafoid
Administrator
Mar 1, 2019, 17:14
Hydreigon:
Your comment is of ZERO help. Unless you have attempted to duplicate the reported issue with this game with MAME 0.207 or have legitimate claims to know what the problem is, you shouldn't be posting notes and quibbling over minor things such as a changed description or commenting and inferring no one has a clue what is happening. In short, your comment does nothing to help the progress of the report. Don't do this again on this site.

...

Crash or Black Screen... I've been here since the report was made and nothing matching either has come up in my testing for any machine in that driver or in either of the two machines I used to test this reported regression. The Issue Log clearly shows the mod who confirmed it also changed the description to better illustrate the problem as they experienced it which they are is totally within their rights to do.

Generally, when there is such a large disparity between confirm (1) and non-confirm (4) it usually means some configuration problem. We have to wait for the original posters and or confirming users to see what needs to be fixed.
User avatar
No.16196
B2K24
Moderator
Mar 1, 2019, 20:34
Sorry for the confusion here.

I somehow had cheat set to 1 in "core misc options" which has not been recommended to do in a very long time. I don't even remember changing that in my mame.ini so I'm a bit puzzled by it. Anyway, I edited the report upon trying to confirm because I'd assumed at the time that the OP experienced the exact same behavior.

Tafoid and other Developers are correct here: if you're working with a fresh install using a default state then you'll have no issues. Confirming this report was a mistake in this case.
User avatar
No.16197
Robbbert
Developer
Mar 1, 2019, 22:12
Changed the summary and description back to what the OP said.

ArcadeGuy - confirm you are using MAME that was downloaded from mamedev's site. If necessary, delete cfg\wofj.cfg, and reset your mame.ini. Try different -video options.
User avatar
No.16198
Hydreigon
Tester
Mar 1, 2019, 23:10
Unable to reproduce on my end now. Most likely a cheats related issue (which I don't even use).
User avatar
No.16199
ArcadeGuy
Tester
Mar 1, 2019, 23:43
The mame build I'm using is MAMEUI32 i only use OpenGL because I think Direct3D is not supported by my pc when I put Direct3D the screen get's all black like this very same issue but that isn't the case here cause I always use OpenGL and all games work fine besides this one
i also allready said i'm not using any cheat or savestate
User avatar
No.16201
Robbbert
Developer
Mar 2, 2019, 04:34
edited on: Mar 2, 2019, 09:44
I suspect a local issue is your problem, but we'll continue for a bit.

Start up MAMEUI and run the game and then exit the game, then exit MAMEUI. You'll find a file called verbose.log . Attach that here.

After doing that, download MAME from the mamedev site, and set it up in a new folder. From the command line, type

>mame wofj -verbose > v.txt

When you start hearing the sound, quit back to the command prompt. You'll find a file called v.txt . Attach that here too. And tell us if the game worked or not.

Just to point out that I just tried both emulators here, with d3d and with opengl, and it worked every time.
User avatar
No.16203
ArcadeGuy
Tester
Mar 2, 2019, 19:14
APPLICATION ERROR #501
File type not allowed for uploads.

this is what it appears on screen when i try to upload verbose.log
User avatar
No.16204
B2K24
Moderator
Mar 2, 2019, 20:29
An option might be to paste the contents of the log to pastebin or a similar site and then link it here.
User avatar
No.16205
ArcadeGuy
Tester
Mar 2, 2019, 20:37
ok i copy pasted to a txt file this time it worked
User avatar
No.16222
Robbbert
Developer
Mar 8, 2019, 16:06
Appears to be a local issue - unable to be reproduced by anyone else.

Also, the OP hasn't supplied requested materials.

Closing.