Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07554 Graphics Minor Always Jan 24, 2020, 18:29 Jan 25, 2020, 14:24
Tester Tafoid View Status Public Platform MAME (Official Binary)
Assigned To hap Resolution Fixed OS Windows Vista/7/8 (64-bit)
Status [?] Resolved Driver m68705prg.cpp
Version 0.217 Fixed in Version 0.218 Build 64-bit
Summary MESS-specific 07554: All machines in m68705prg.cpp: No longer shows LED value (default 000) when booting
Description No longer shows LED value (default 000) when booting,
It does show when you start the the procedure (CTRL = reset)
Steps To Reproduce
Additional Information
Flags
Regression Version 0.217
Affected Sets / Systems All machines in m68705prg.cpp
Attached Files
png file icon 705p3prg-diff.png (30,244 bytes) Jan 24, 2020, 18:30 Uploaded by Tafoid
705p3prg (diff snap)
Tafoid
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.17372
Robbbert
Developer
Jan 25, 2020, 05:57
edited on: Jan 25, 2020, 05:59
Compared 0.209 vs current git. Confirmed the change in behaviour.

If you let it do a programming sequence, then quit and start over, the display shows 001, same as the old version.

This new operation may well be correct, but I wasn't able to locate a manual to find out.
User avatar
No.17373
hap
Developer
Jan 25, 2020, 13:01
edited on: Jan 25, 2020, 13:06
Try moving these 3 lines from machine_start to machine_reset

m_digits[0] = s_7seg[(m_addr >> 0) & 0x0f];
m_digits[1] = s_7seg[(m_addr >> 4) & 0x0f];
m_digits[2] = s_7seg[(m_addr >> 8) & 0x0f];

*edit* yeah that was it