Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07620 Gameplay Minor Always Apr 25, 2020, 05:16 May 30, 2020, 14:45
Tester sasuke View Status Public Platform MAME (Official Binary)
Assigned To hap Resolution Fixed OS Windows 10 (64-bit)
Status [?] Resolved Driver tubep.cpp
Version 0.220 Fixed in Version 0.222 Build 64-bit
Summary 07620: tubep, tubepb: "GAME OVER" display is skipped
Description When the game is over, "GAME OVER" will not be displayed, and the ranking displayed soon.
In PCB, after displayng "GAME OVER", display ranking with playing demo BGM.

MAME Movie


PCB Movie



It may be the same bug that there is no waiting time after the ending staff names are shown and finished.
But I've never seen the ending in PCB, so I'm not comparing it.


FYI: PS4 verison
Steps To Reproduce
Additional Information
Flags
Regression Version
Affected Sets / Systems tubep, tubepb
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
7
User avatar
No.17568
sasuke
Tester
Apr 25, 2020, 07:57
My guess is that waiting process for the ending or game over music to finish playing doesn't seem to be working.
User avatar
No.17689
sasuke
Tester
May 29, 2020, 06:59
edited on: May 29, 2020, 14:44
From my checking the logic, it seems that the logic of waiting for end of music is not working.
It's not just the game over, but the stage clearing and ending have the same problem.
These seem to read the main CPU's port $A0 and wait by loop until bit5 is 0.
This bit appears to be meant to detect that the music has finished playing, but it is currently assigned to "In Game Sounds" on the DIPSW.
The sound CPU outputs "00" to the port $07 which is now unknown, at the timing of the end of this playing.
The two are probably related.
User avatar
No.17690
hap
Developer
May 29, 2020, 14:00
Yes, it sounds like you're on the right track. maincpu port $A0 bit 5 looks more like sound communication and not a dip switch. In fact, the game will lock up at game over when it's off.

I don't see how sound cpu port 7 is involved though. If you make the maincpu port react to soundcpu port 7 value $00, you will get missing sound effects. It's possibly unrelated, port 7 could be for filtering/volume instead.
User avatar
No.17691
hap
Developer
May 29, 2020, 15:35
Ah, port 7 is soundlatch acknowledge
User avatar
No.17692
dink
Tester
May 30, 2020, 00:43
sasuke, hap, nice work on this one!
User avatar
No.17693
hap
Developer
May 30, 2020, 08:17
Feel free to copy my changes under FBN license.
(tubep driver is GPL2)
User avatar
No.17694
sasuke
Tester
May 30, 2020, 14:45
Wow, that was a perfect fix while I was looking into it. Awesome, and thanks!