Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07710 Known Issues/To-Do's Minor Always 22 days ago 19 days ago
Tester rcoltrane View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Acknowledged Driver atarisy1.cpp
Version 0.222 Fixed in Version Build 64-bit
Summary 07710: indytemp: missing voices during attract mode
Description It's a regression, in MAME version 0.218 the voices were fine in attract mode, now in version 0.222 they are gone. I know there's a warning now saying that the sound has problems, but since the voices in attract mode were working before, they should keep working.
Steps To Reproduce Just start the game in latest MAME version and compare it to MAME version 0.218. The voices in attract mode were working before.
Additional Information
Flags
Regression Version 0.218
Affected Sets / Systems indytemp
Attached Files
 
Relationships
There are no relationship linked to this issue.
Notes
1
User avatar
No.17833
Tafoid
Administrator
22 days ago
This game and some others now have imperfect audio flag.

https://github.com/mamedev/mame/commit/9eabe008a1bc6c96ce6a00953d4b5b48552827dd
marble, peterpak: Remove TMS5220C and VIA from configuration
indytemp: Downgrade to MACHINE_IMPERFECT_SOUND with note on regression

Known and mentioned in driver as well
   TODO:
        * indytemp: "Welcome" doesn't play at start (regression). Code for
          speech (0x46) is written but fails to play due to timing issues.