Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07776 Graphics Minor Always 28 days ago 16 days ago
Tester giro-X View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows 10 (64-bit)
Status [?] Acknowledged Driver taito_f3.cpp
Version 0.225 Fixed in Version Build 64-bit
Summary 07776: dariusgx: Background and sprites not behaving properly in Zone D (1P side) and Zone U (2P side)
Description This problem is happening only during Zone D, if you started the game with Player 1, or in Zone U if game started with Player 2 (same rounds, just switched in position).
In this zone, the background is missing, the sprites for wall-type objects in the underwater section are missing (collision still works) and, when on surface, the sea hides player and projectiles partially or fully. (See an example screenshot on attachment)
EDIT: Among these behaviours, the missing sprites of seabed (walls) are regular on board too. The missing background happens on board too, although while in MAME sometimes we see the sea or the sky underwater, on board there is absolute nothing except for the sea displayed once the boss makes its entrance. The sea also never hides other sprites on board.
Steps To Reproduce Insert a credit and start the game on 1P side, follow the route A-B-D (faster), or start the game on 2P side and play through 21 levels (~1hr of time).
Additional Information First occurrence that I found of this behaviour is MAME 0.194. Before MAME 0.193, the level was displayed with full background and sprites (which looked fine, but even that doesn't match the actual hardware behaviour, apparently).
This bug does not occur on dariusg and its clones, and doesn't occur in attract mode - the attract mode shows a random zone between A and F of the 1P side routes, thus including Zone D, with proper graphics.
Flags
Regression Version
Affected Sets / Systems dariusgx
Attached Files
zip file icon u_save.zip (728,305 bytes) 23 days ago Uploaded by giro-X
Quick savestate to 2P side zone U, mame194 (the Zone letter shown on top of screen may not match due to savestate, as the save starts after the letter is updated)
png file icon dariusgx_mame194_zoneUpart1.png (24,621 bytes) 23 days ago Uploaded by giro-X
From the savestate on mame 0.194 - sea is visible and hides all sprites
giro-X
png file icon dariusgx_mame194_zoneUpart3.png (19,529 bytes) 23 days ago Uploaded by giro-X
From the savestate on mame 0.194 - sea now hides player, enemy and projectiles completely.
giro-X
Relationships
There are no relationship linked to this issue.
Notes
3
User avatar
No.18126
giro-X
Tester
23 days ago
edited on: 23 days ago
Update. So, I have found this video about Darius Gaiden Extra version that shows 2P Zone U (last part of video)
https://www.nicovideo.jp/watch/sm29475934
as part of a 9-videos-long replay on 2P side route. I don't know whether this is made on actual hardware or not, I "thought" so after viewing the videos with zones G to J, reminding of the bug #01922 about traces of objects not displayed when the scene is changing... (this behaviour seems to happen on this recording, hence why I think it's on actual hw)

So getting to Zone U, well, the background is still black/missing, and parts of the seabed is missing too. Still there's a different behaviour.
Dividing the Zone in three sub-sectors (part 1: when the ship is flying in sky; part 2: when the ship is submerged in the sea; part 3: when the ship rises and flies again above the sea):
-Part 1: in MAME the sea is visible and hides partially the player and projectiles. In the niconico video, we don't even see the sea.
-Part 2: in MAME there is a visible part of water at the top. In the niconico video, still no background.
-Part 3: the sky is missing and the sea is visible in both circumstances, but in MAME the sea fully hides player and stuff.

So, even if still I don't know if that video is made on original hw, it might be that part of the chaos we see is not a real MAME bug, but it still might not match the actual behaviour. I don't know.

I'll leave more attachments to quickly understand the whole situation. Of course, to have a video on original board or to be sure that one is, would help to clarify.
User avatar
No.18127
giro-X
Tester
23 days ago
Okay, yes, there is also this video
(zone U starts at 1:20:40) which seems to be from original board, and it happens like I described above.
Readjusting the bug summary a little bit. My apologies for the extra passages that were made in the process, it is my first time reporting a bug.
User avatar
No.18133
Haze
Senior Tester
20 days ago
edited on: 20 days ago
I think previous versions of MAME had a hack in the code to stop some bad code in the games going beyond the RAM areas they were meant to be writing and destroying line tables.

If the removal of those hacks is responsible for this bug occurring them I'm somewhat inclined to think this might happen on original hardware. To the best of my knowledge this version of the game wasn't a wide release, and was maybe not well tested?