Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07833 Color/Palette Minor Sometimes Jan 1, 2021, 01:40 Jan 1, 2021, 21:41
Tester jkburks View Status Public Platform MAME (Official Binary)
Assigned To AJR Resolution Fixed OS Windows 10 (64-bit)
Status [?] Resolved Driver tickee.cpp
Version 0.227 Fixed in Version 0.228 Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 07833: ghoshunt, mouseatk, tickee, tutstomb: Random chance of launching with missing colors
Description These 4 games randomly load with incorrect colors. They appear to be missing red.
Steps To Reproduce Make a clean test install of 0.226 or 0.227.
Launch any of these four games.
If they load with correct colors, exit and launch them again from the UI or with shift + F3.
I have noticed that you must release the shift key to get the correct hard reset.
Sometimes they load with missing colors on the first try, sometimes it takes 10 or more times.
Additional Information Deleting nvram folders seems to have no affect on the % chance of missing colors.
I have had them load with missing colors on the first try before the nvram was created and I have had them load correctly a dozen times, then switch to bad colors, then switch back to correct colors on subsequent tries. This can happen from the command line, the UI, or Shift + F3.
I was unable to reproduce this issue with 0.225 or earlier.
Mallet Madness & Rapid Fire seem not to be affected.
Attached example snaps.
Github Commit
Flags
Regression Version 0.226
Affected Sets / Systems ghoshunt, mouseatk, tickee, tutstomb
Attached Files
jpg file icon tickee_color.jpg (235,495 bytes) Jan 1, 2021, 01:40 Uploaded by jkburks
Examples of missing colors
jkburks
Relationships
There are no relationship linked to this issue.
Notes
4
User avatar
No.18310
Tafoid
Administrator
Jan 1, 2021, 02:01
I did see this in testing and mentioned it, but it was random/inconsistently happening.
More than likely something requiring initialization is missing.
User avatar
No.18312
AJR
Developer
Jan 1, 2021, 04:20
672787fe45e9d508b112293fc59ae99b79b3ce9f is a possible fix for this issue.
User avatar
No.18314
Robbbert
Developer
Jan 1, 2021, 12:20
tickee was the only one to misbehave for me, being blue and black.

After the patch, it's working, but these days one can never be sure if a bug is truly fixed.
User avatar
No.18317
Tafoid
Administrator
Jan 1, 2021, 21:40
In my testing they seem corrected.
If they happen to regress again during the next dev period, I will re-open