Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
07893 Crash/Freeze Critical (emulation) Always Mar 1, 2021, 16:04 13 days ago
Tester Skeleton081983 View Status Public Platform MAME (Official Binary)
Assigned To AJR Resolution Fixed OS Windows 10 (64-bit)
Status [?] Resolved Driver atetris.cpp
Version 0.229 Fixed in Version 0.233GIT Build 64-bit
Fixed in Git Commit 16e300e Github Pull Request #
Summary 07893: atetrisb2, atetrisb3: Game stucks at black screen
Description When I launch atetrisb2 or atetrisb3 (bootleg of Tetris by Atari with Texas Instruments SN76489A sound chip instead of Atari Pokey) the game stucks at black screen. If i try to enter in service mode, appears a text at the bottom of the screen, after a few seconds the text disappears and appears continuously. Clones working fine on 0.228 and older version.
Steps To Reproduce
Additional Information
Github Commit
Flags
Regression Version 0.229
Affected Sets / Systems atetrisb2, atetrisb3
Attached Files
png file icon 0000.png (763 bytes) Mar 1, 2021, 16:04 Uploaded by Skeleton081983
Text that appear at bottom of screen if I try to enter in service mode
Skeleton081983
Relationships
There are no relationship linked to this issue.
Notes
2
User avatar
No.18504
Tafoid
Administrator
Mar 1, 2021, 17:24
Yes.
I had reported this when it happened but it wasn't fixed before release.
https://github.com/mamedev/mame/commit/f4f9a3284b9fcb9b6c1c521d7650611c4c5ff9ea#commitcomment-46909007
User avatar
No.18938
Robbbert
Developer
13 days ago
Does this fix it? https://github.com/mamedev/mame/commit/16e300e6301fe78a10fcbb4f2554e24ca9ac33cb