Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
08170 Gameplay Major Always 14 days ago 9 days ago
Tester Hammy View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows Vista/7/8 (64-bit)
Status [?] Acknowledged Driver megasys1.cpp
Version 0.239 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 08170: plusalph: [possible] Issues with initial game start / player spawn
Description Game should begin with a plane / pea shooter.
HOWEVER after a few games / demo cycles the player with spawn with the higher power ship from the attract mode.
Steps To Reproduce Run the game , play a few credits and run for a few demo loops.
Credit up as normal when a HIGH POWER ship is on the DEMO screen.
You will start with this ship.
NB. It it SEMI-RARE to trigger but will happen.
Additional Information
Github Commit
Flags Possible
Regression Version
Affected Sets / Systems plusalph
Attached Files
png file icon 0000.png (15,500 bytes) 14 days ago Uploaded by Hammy
Hammy
png file icon 0001.png (15,535 bytes) 14 days ago Uploaded by Hammy
Incorrect
Hammy
png file icon 0002.png (15,581 bytes) 14 days ago Uploaded by Hammy
Incorrect 2
Hammy
Relationships
There are no relationship linked to this issue.
Notes
5
User avatar
No.19611
Haze
Senior Tester
14 days ago
edited on: 14 days ago
are you sure this isn't some weird "incentive to play" type mechanic, much like some games lower rank if left in attract mode.
User avatar
No.19612
Hammy
Tester
14 days ago
Not sure, seems to be kinda random. Maybe MCU related or a "feature".
Happens on patched version on hardware too , awaiting tests on real romboard.
FWIW the patch:
<nop @12a0 = 580C9E88 714E714E C851F6FF FC440000>
User avatar
No.19629
Tafoid
Administrator
11 days ago
The demonstration seems to look like your recording, at least showing the different ships each cycle of the demonstration.
It isn't unreasonable to believe there is something to starting with the ship in demonstration. You could attempt to verify if the same happens on your multi-board setup?

User avatar
No.19657
Hammy
Tester
9 days ago
edited on: 9 days ago
The demo is correct on both , it's the initial spawn of the player upon game start.
It's very rare to trigger, and i attempted many times a savestate on mame and the fault was not duplicated when reloading a state that had the glitch.

I think this so rare it must be a bug / cheat / feature in the original game but honestly cannot be sure!

We are awaiting tests on a genuine romboard the multiboard can't be trusted ;)
User avatar
No.19659
Haze
Senior Tester
9 days ago
edited on: 9 days ago
I'm inclined to think it's a hidden feature. We tend to see arcades as 'mechanical' and following a fixed pattern, but sometimes they didn't.