Viewing Issue Advanced Details
ID Category [?] Severity [?] Reproducibility Date Submitted Last Update
08538 Graphics Minor Always Dec 27, 2022, 23:59 28 days ago
Tester Gryzor1363 View Status Public Platform MAME (Official Binary)
Assigned To Resolution Open OS Windows Vista/7/8 (64-bit)
Status [?] Confirmed Driver
Version 0.250 Fixed in Version Build 64-bit
Fixed in Git Commit Github Pull Request #
Summary 08538: snes [lionkingu]: Garbage line at the bottom of the display area in The Lion King (Level 1)
Description Permanent glitching in a thin line with vivid colors at the bottom of the screen, right from the start of level one. It also seems to vary relative to movement, appears to be a partial, corrupt reproduction of other lines of the display.

 Issues does not seem to affect all levels of the game, namely the ones visible in the demo mode (if you wait enough in the title screen for it to trigger) namely the elephant graveyard, or the waterfalls (the latter being likely due to the fact that we do not see the player reach the bottom platform I believe).

I will update this report after further progressing in the game.
Steps To Reproduce Start a new game and observe the lower part of the screen, which will always display variable vivid colored lines moving and evolving in concert with the player moving left or right.
Additional Information I do not know for certain which is the regression version. But I know for a fact, after retesting a moment ago, that v0.197 does not have that issue.
It should also be noted that I used that version via MAMUI64, whereas I experienced the graphical glitches in 0.250 with a clean version of Mame using only the built-in GUI to launch the snes system and then load the game via the file manager, in case that information is of any relevance to the topic at hand.
Github Commit
Flags
Regression Version
Affected Sets / Systems snes [lionkingu]
Attached Files
png file icon 0001.png (1,898,306 bytes) Dec 27, 2022, 23:59 Uploaded by Gryzor1363
png file icon 0000.png (2,020,588 bytes) Dec 28, 2022, 00:00 Uploaded by Gryzor1363
png file icon 0002.png (2,409,202 bytes) Dec 28, 2022, 00:00 Uploaded by Gryzor1363
Relationships
There are no relationship linked to this issue.
Notes
4
User avatar
No.20983
Robbbert
Senior Tester
31 days ago
Tested with current git (just after 0.251), and there's a black line at the bottom when started. After pressing 1 to begin, this area becomes various colours, but they aren't changing.

I loaded the game via the command line

>mame snes lionkingu
User avatar
No.20986
Gryzor1363
Tester
29 days ago
edited on: 29 days ago
Wow Robbbert, did I expect you of all people to react to my report, thanks for confirming. For my part the colors tend to sometimes move along with Simba,go figure, might depend on the setting ? Anyway I used Mame without any frontend for that ticket contrary to all previous ones I raised, for a reason that you must be the most adequate person to understand on the entire Mame scene :p

Please allow me to take this opportunity to thank you big time for your work on this frontend. Indeed use of Mameui64's complete and powerful interface pretty much defined my experience and use of Mame over the past years, carefully balancing between INIs and the GUI features,enjoying all the art day after day.

Best wishes to all.

-G
User avatar
No.20988
Robbbert
Senior Tester
29 days ago
edited on: 10 days ago
Thanks for the kind words.
User avatar
No.20989
Gryzor1363
Tester
28 days ago
I'll be sure to finally activate an account where due, thanks a lot for your message and suggestion.

So far I've always been able to gather whatever piece of information I wanted merely by doing in-depth searches on topics without adding any noise of my own, but raising more such reports here (and sometimes on github) led me to adopt a more proactive posture overtime and appreciate contributing in a way beneficial to other people as well, and not just wait for a given issue to be raised in order to be addressed for me to grab the info just for myself, without forwarding it further.